$re = '/是(.*色)/m';
$str = '苹果是绿色的
橙子是橙色的
香蕉是黄色的
乌鸦是黑色的
乌鸦是黄棕色的';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);