import re
regex = re.compile(r"是(.*色)", flags=re.MULTILINE)
test_str = ("苹果是绿色的\n"
"橙子是橙色的\n"
"香蕉是黄色的\n"
"乌鸦是黑色的\n"
"乌鸦是黄棕色的")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")