const regex = new RegExp('是(.*色)', 'gm')
const str = `苹果是绿色的
橙子是橙色的
香蕉是黄色的
乌鸦是黑色的
乌鸦是黄棕色的`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}