using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"是(.*色)";
string input = @"苹果是绿色的
橙子是橙色的
香蕉是黄色的
乌鸦是黑色的
乌鸦是黄棕色的";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}