#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sU)".*(?<!\\)""
Local $sString = "key1 = "valu\"e1"" & @CRLF & _
"key2 = "value2"" & @CRLF & _
"key3 = "val" & @CRLF & _
"" & @CRLF & _
""" & @CRLF & _
"key4 = "val\"" & @CRLF & _
"..."" & @CRLF & _
"key5 = 123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")