import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\".*(?<!\\\\)\"";
final String string = "key1 = \"valu\\\"e1\"\n"
+ "key2 = \"value2\"\n"
+ "key3 = \"val\n\n"
+ "\"\n"
+ "key4 = \"val\\\"\n"
+ "...\"\n"
+ "key5 = 123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}