using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @""".*(?<!\\)""";
string input = @"key1 = ""valu\""e1""
key2 = ""value2""
key3 = ""val
""
key4 = ""val\""
...""
key5 = 123
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}