import re
regex = re.compile(r"\".*(?<!\\)\"", flags=re.DOTALL)
test_str = ("key1 = \"valu\\\"e1\"\n"
"key2 = \"value2\"\n"
"key3 = \"val\n\n"
"\"\n"
"key4 = \"val\\\"\n"
"...\"\n"
"key5 = 123\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")