$re = '/".*(?<!\\\\)"/sU';
$str = 'key1 = "valu\\"e1"
key2 = "value2"
key3 = "val
"
key4 = "val\\"
..."
key5 = 123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);