use strict;
my $str = 'Green Day - Basket Case (live)
ATB - Ecstasy (feat. Zara)
ATB - Behind (radio remix)';
my $regex = qr/\s*\([^)]*\)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";