import Foundation
let pattern = #"\s*\([^)]*\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Green Day - Basket Case (live)
ATB - Ecstasy (feat. Zara)
ATB - Behind (radio remix)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)