$re = '/\s*\([^)]*\)/';
$str = 'Green Day - Basket Case (live)
ATB - Ecstasy (feat. Zara)
ATB - Behind (radio remix)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;