#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\s*\bCost\s+)(?<cost>.+?)(?:\s*\bMaterials\s+)(?<material>.+?)(?:\s*\bLocation\s+)(?<location>.+)"
Local $sString = "Cost £45 Materials glue, plastic, wood and nails Location Sale, Manchester North England."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")