import Foundation
let pattern = #"(?:\s*\bCost\s+)(?<cost>.+?)(?:\s*\bMaterials\s+)(?<material>.+?)(?:\s*\bLocation\s+)(?<location>.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Cost £45 Materials glue, plastic, wood and nails Location Sale, Manchester North England."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}