$re = '/(?:\s*\bCost\s+)(?<cost>.+?)(?:\s*\bMaterials\s+)(?<material>.+?)(?:\s*\bLocation\s+)(?<location>.+)/';
$str = 'Cost £45 Materials glue, plastic, wood and nails Location Sale, Manchester North England.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);