const regex = /(?:\s*\bCost\s+)(?<cost>.+?)(?:\s*\bMaterials\s+)(?<material>.+?)(?:\s*\bLocation\s+)(?<location>.+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s*\\bCost\\s+)(?<cost>.+?)(?:\\s*\\bMaterials\\s+)(?<material>.+?)(?:\\s*\\bLocation\\s+)(?<location>.+)', '')
const str = `Cost £45 Materials glue, plastic, wood and nails Location Sale, Manchester North England.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}