package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\s*\bCost\s+)(?<cost>.+?)(?:\s*\bMaterials\s+)(?<material>.+?)(?:\s*\bLocation\s+)(?<location>.+)`)
var str = `Cost £45 Materials glue, plastic, wood and nails Location Sale, Manchester North England.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}