import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b(?'first_word'[a-z](?!([[:alnum:]]*_)(?# the word doesn't contain underscores))(?:[a-z0-9]*)))|(\\G(?'trailing_word'[A-Z][a-z0-9]*))";
final String string = "camelCase\n"
+ "camel\n"
+ "camelCaseCase\n"
+ "camel684Case\n"
+ "ca45melCase\n"
+ "camelCase6523Case\n"
+ "camelCaseCaseCaseCaseCase\n"
+ "camelCCase\n"
+ "PascalCase\n"
+ "// some random commentary with Capitalized letters\n"
+ "camel_Snake_Case\n";
final String subst = "\\L${first_word}${trailing_word:+_\\L${trailing_word}:}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}