const regex = /(\b(?'first_word'[a-z](?!([[:alnum:]]*_)(?# the word doesn't contain underscores))(?:[a-z0-9]*)))|(\G(?'trailing_word'[A-Z][a-z0-9]*))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b(?\'first_word\'[a-z](?!([[:alnum:]]*_)(?# the word doesn\'t contain underscores))(?:[a-z0-9]*)))|(\\G(?\'trailing_word\'[A-Z][a-z0-9]*))', 'gm')
const str = `camelCase
camel
camelCaseCase
camel684Case
ca45melCase
camelCase6523Case
camelCaseCaseCaseCaseCase
camelCCase
PascalCase
// some random commentary with Capitalized letters
camel_Snake_Case
`;
const subst = `\L${first_word}${trailing_word:+_\L${trailing_word}:}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);