use strict;
my $str = 'camelCase
camel
camelCaseCase
camel684Case
ca45melCase
camelCase6523Case
camelCaseCaseCaseCaseCase
camelCCase
PascalCase
// some random commentary with Capitalized letters
camel_Snake_Case
';
my $regex = qr/(\b(?'first_word'[a-z](?!([[:alnum:]]*_)(?# the word doesn't contain underscores))(?:[a-z0-9]*)))|(\G(?'trailing_word'[A-Z][a-z0-9]*))/mp;
my $subst = '\\L${first_word}${trailing_word:+_\\L${trailing_word}:}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";