import re
regex = re.compile(r"(\b(?'first_word'[a-z](?!([[:alnum:]]*_)(?# the word doesn't contain underscores))(?:[a-z0-9]*)))|(\G(?'trailing_word'[A-Z][a-z0-9]*))", flags=re.MULTILINE)
test_str = ("camelCase\n"
"camel\n"
"camelCaseCase\n"
"camel684Case\n"
"ca45melCase\n"
"camelCase6523Case\n"
"camelCaseCaseCaseCaseCase\n"
"camelCCase\n"
"PascalCase\n"
"// some random commentary with Capitalized letters\n"
"camel_Snake_Case\n")
subst = "\\L${first_word}${trailing_word:+_\\L${trailing_word}:}"
result = regex.sub(subst, test_str)
if result:
print(result)