const regex = /m(\S+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('m(\\S+)', 'g')
const str = `mFoo = foo;
mBar = bar;
// For backreference you can use \`\\1\` or \`\$1\`.`;
const subst = `this.m$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);