$re = '/m(\S+)/';
$str = 'mFoo = foo;
mBar = bar;
// For backreference you can use `\\1` or `$1`.';
$subst = "this.m$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;