// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"m(\S+)").unwrap();
let string = "mFoo = foo;
mBar = bar;
// For backreference you can use `\\1` or `$1`.";
let substitution = "this.m$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}