import re
regex = re.compile(r"m(\S+)")
test_str = ("mFoo = foo;\n"
"mBar = bar;\n\n"
"// For backreference you can use `\\1` or `$1`.")
subst = "this.m$1"
result = regex.sub(subst, test_str)
if result:
print(result)