re = /m(\S+)/
str = 'mFoo = foo;
mBar = bar;
// For backreference you can use `\\1` or `$1`.'
subst = 'this.m$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result