using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^-\s].*\n(-\s+[^\s-].*(?:\n-\s+[^\s-].*)*)";
string input = @"some text
- list
- list
- list
more text
- another list
- another list
- another list
more text
- another list
- -
- another list
more text
- another list
-
- another list";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}