import re
regex = re.compile(r"^[^-\s].*\n(-\s+[^\s-].*(?:\n-\s+[^\s-].*)*)", flags=re.MULTILINE)
test_str = ("some text\n"
"- list\n"
"- list\n"
"- list\n"
"more text\n"
"- another list\n"
"- another list\n"
"- another list\n\n"
"more text\n"
"- another list\n"
"- -\n"
"- another list\n\n"
"more text\n"
"- another list\n"
"- \n"
"- another list")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")