package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^-\s].*\n(-\s+[^\s-].*(?:\n-\s+[^\s-].*)*)`)
var str = `some text
- list
- list
- list
more text
- another list
- another list
- another list
more text
- another list
- -
- another list
more text
- another list
-
- another list`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}