$re = '/^[^-\s].*\n(-\s+[^\s-].*(?:\n-\s+[^\s-].*)*)/m';
$str = 'some text
- list
- list
- list
more text
- another list
- another list
- another list
more text
- another list
- -
- another list
more text
- another list
-
- another list';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);