import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/www\\.abcde\\.com\\/.+(?=\")";
final String string = "<a href=\"https://www.abcde.com/some-link-1\">test</a>\n"
+ "<a href=\"https://www.abcde.com/some-link-2\">test</a>\n"
+ "<a href=\"https://www.abcde.com/some-link-3\">test</a>\n"
+ "<a href=\"https://www.abcde.com/some-link-4\">test</a>\n"
+ "<a href=\"https://www.abcde.com/some-link-5\">test</a>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}