use strict;
my $str = '<a href="https://www.abcde.com/some-link-1">test</a>
<a href="https://www.abcde.com/some-link-2">test</a>
<a href="https://www.abcde.com/some-link-3">test</a>
<a href="https://www.abcde.com/some-link-4">test</a>
<a href="https://www.abcde.com/some-link-5">test</a>
';
my $regex = qr/https:\/\/www\.abcde\.com\/.+(?=")/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}