import Foundation
let pattern = #"https:\/\/www\.abcde\.com\/.+(?=")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<a href="https://www.abcde.com/some-link-1">test</a>
<a href="https://www.abcde.com/some-link-2">test</a>
<a href="https://www.abcde.com/some-link-3">test</a>
<a href="https://www.abcde.com/some-link-4">test</a>
<a href="https://www.abcde.com/some-link-5">test</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)