$re = '/https:\/\/www\.abcde\.com\/.+(?=")/';
$str = '<a href="https://www.abcde.com/some-link-1">test</a>
<a href="https://www.abcde.com/some-link-2">test</a>
<a href="https://www.abcde.com/some-link-3">test</a>
<a href="https://www.abcde.com/some-link-4">test</a>
<a href="https://www.abcde.com/some-link-5">test</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);