const regex = /https:\/\/www\.abcde\.com\/.+(?=")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/www\\.abcde\\.com\\\/.+(?=")', 'g')
const str = `<a href="https://www.abcde.com/some-link-1">test</a>
<a href="https://www.abcde.com/some-link-2">test</a>
<a href="https://www.abcde.com/some-link-3">test</a>
<a href="https://www.abcde.com/some-link-4">test</a>
<a href="https://www.abcde.com/some-link-5">test</a>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}