# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/http\:\\\\link\.brightcove\.com\\/services\\/player\\/bcpid2271076355001\?bckey\=AQ\~\~\,AAACEKku5Lk\~\,VOK\-A2n1zOLottqmiTxspiAGnDoD6coZ&bctid\=4810226349001/\/brn9999\/application.htm/g;t' <<< "http://link.brightcove.com/services/player/bcpid2271076355001?bckey=AQ~~,AAACEKku5Lk~,VOK-A2n1zOLottqmiTxspiAGnDoD6coZ&bctid=4810226349001"