import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http\\:\\\\\\\\link\\.brightcove\\.com\\/services\\/player\\/bcpid2271076355001\\?bckey\\=AQ\\~\\~\\,AAACEKku5Lk\\~\\,VOK\\-A2n1zOLottqmiTxspiAGnDoD6coZ&bctid\\=4810226349001";
final String string = "http://link.brightcove.com/services/player/bcpid2271076355001?bckey=AQ~~,AAACEKku5Lk~,VOK-A2n1zOLottqmiTxspiAGnDoD6coZ&bctid=4810226349001";
final String subst = "/brn9999/application.htm";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}