using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http\:\\\\link\.brightcove\.com\/services\/player\/bcpid2271076355001\?bckey\=AQ\~\~\,AAACEKku5Lk\~\,VOK\-A2n1zOLottqmiTxspiAGnDoD6coZ&bctid\=4810226349001";
string substitution = @"/brn9999/application.htm";
string input = @"http://link.brightcove.com/services/player/bcpid2271076355001?bckey=AQ~~,AAACEKku5Lk~,VOK-A2n1zOLottqmiTxspiAGnDoD6coZ&bctid=4810226349001";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}