# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"http\:\\\\link\.brightcove\.com\/services\/player\/bcpid2271076355001\?bckey\=AQ\~\~\,AAACEKku5Lk\~\,VOK\-A2n1zOLottqmiTxspiAGnDoD6coZ&bctid\=4810226349001"
test_str = "http://link.brightcove.com/services/player/bcpid2271076355001?bckey=AQ~~,AAACEKku5Lk~,VOK-A2n1zOLottqmiTxspiAGnDoD6coZ&bctid=4810226349001"
subst = "/brn9999/application.htm"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.