#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "http\:\\\\link\.brightcove\.com\/services\/player\/bcpid2271076355001\?bckey\=AQ\~\~\,AAACEKku5Lk\~\,VOK\-A2n1zOLottqmiTxspiAGnDoD6coZ&bctid\=4810226349001"
Local $sString = "http://link.brightcove.com/services/player/bcpid2271076355001?bckey=AQ~~,AAACEKku5Lk~,VOK-A2n1zOLottqmiTxspiAGnDoD6coZ&bctid=4810226349001"
Local $sSubst = "/brn9999/application.htm"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)