package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[\w.!#$%&’*+\/=?^`{|}~-]+@(protonmail|hush)+(?:\.[\w-]+)*\b`)
var str = `test@protonmail.com
test@hush.com
test@protonmail_other.com
test@hush_other.com
test@gmail.com
test@hotmail.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}