const regex = /\b[\w.!#$%&’*+\/=?^`{|}~-]+@(protonmail|hush)+(?:\.[\w-]+)*\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[\\w.!#$%&’*+\\\/=?^`{|}~-]+@(protonmail|hush)+(?:\\.[\\w-]+)*\\b', 'g')
const str = `test@protonmail.com
test@hush.com
test@protonmail_other.com
test@hush_other.com
test@gmail.com
test@hotmail.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}