import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[\\w.!#$%&’*+\\/=?^`\\{|\\}~-]+@(protonmail|hush)+(?:\\.[\\w-]+)*\\b";
final String string = "test@protonmail.com\n"
+ "test@hush.com\n"
+ "test@protonmail_other.com\n"
+ "test@hush_other.com\n"
+ "test@gmail.com\n"
+ "test@hotmail.com\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}