re = /\b[\w.!#$%&’*+\/=?^`{|}~-]+@(protonmail|hush)+(?:\.[\w-]+)*\b/
str = 'test@protonmail.com
test@hush.com
test@protonmail_other.com
test@hush_other.com
test@gmail.com
test@hotmail.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end