$re = '/\b[\w.!#$%&’*+\/=?^`{|}~-]+@(protonmail|hush)+(?:\.[\w-]+)*\b/';
$str = 'test@protonmail.com
test@hush.com
test@protonmail_other.com
test@hush_other.com
test@gmail.com
test@hotmail.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);