using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^I get result one (.+?) and result two (.+?)$";
string input = @"I get result one hi and result two hello
I get result one hi and result two hello from microservice
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}