// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^I get result one (.+?) and result two (.+?)$").unwrap();
let string = "I get result one hi and result two hello
I get result one hi and result two hello from microservice
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}