re = /^I get result one (.+?) and result two (.+?)$/m
str = 'I get result one hi and result two hello
I get result one hi and result two hello from microservice
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end