#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^The thing is.*\b(S\d)(?!.*\b(?:blue|red)\b)"
Local $sString = "TRUE" & @CRLF & _
"The thing is S2w697 and green" & @CRLF & _
"The thing is S2e697 and yellow" & @CRLF & _
"The thing is S2b697 and pink" & @CRLF & _
"" & @CRLF & _
"FALSE" & @CRLF & _
"The thing is S25697 and blue" & @CRLF & _
"The thing is S256b7 and red" & @CRLF & _
"The thing is S2e697 and blue thing" & @CRLF & _
"The thing is S2b697 and red thing"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")