use strict;
my $str = 'TRUE
The thing is S2w697 and green
The thing is S2e697 and yellow
The thing is S2b697 and pink
FALSE
The thing is S25697 and blue
The thing is S256b7 and red
The thing is S2e697 and blue thing
The thing is S2b697 and red thing';
my $regex = qr/^The thing is.*\b(S\d)(?!.*\b(?:blue|red)\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}